faq обучение настройка
Текущее время: Вт дек 10, 2019 08:55

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 7 ] 
Автор Сообщение
СообщениеДобавлено: Сб июн 22, 2013 16:53 
Не в сети

Зарегистрирован: Ср сен 07, 2011 10:51
Сообщений: 22
Доброе время суток!

Имеем достаточно большую сеть, состоящую из DGS-3610-26G в центре топологии, и DES-3200-28 на каждом доме в городе.

В сети присутвуют кольца. Поднят RSTP.

Кусок схемы сети под спойлером, где "кругом" обозначен DGS-3610, "прямоугольники" - DES-3200-28:
Скрытый текст: показать
Изображение


Настройка 3610:
Скрытый текст: показать
Kernel#sh ru | in spannin
spanning-tree max-hops 40
spanning-tree loopguard default
spanning-tree tx-hold-count 6
spanning-tree portfast bpdufilter default
spanning-tree portfast bpduguard default
spanning-tree tc-protection
spanning-tree mode rstp
spanning-tree mst configuration
spanning-tree mst 0 priority 0
spanning-tree

interface GigabitEthernet 0/1
switchport mode trunk
switchport trunk allowed vlan remove 2-2000,2200-4094
storm-control broadcast level 20
storm-control multicast
duplex full
speed 1000
lldp compliance cdp
nfpp nd-guard enable
no nfpp ip-guard enable
nfpp dhcp-guard enable
no nfpp icmp-guard enable
no nfpp arp-guard enable
mls qos trust dscp
rldp port unidirection-detect warning
rldp port bidirection-detect warning
rldp port loop-detect warning
spanning-tree mst 0 cost 1000
spanning-tree mst 0 port-priority 0
description Mendeleeva 61
Kernel#sh ru int G 0/2

Building configuration...
Current configuration : 547 bytes
!
interface GigabitEthernet 0/2
switchport mode trunk
switchport trunk allowed vlan remove 2-10,12-2000,2200-4094
storm-control broadcast level 20
storm-control multicast
duplex full
speed 1000
nfpp nd-guard enable
no nfpp ip-guard enable
nfpp dhcp-guard enable
no nfpp icmp-guard enable
no nfpp arp-guard enable
rldp port unidirection-detect warning
rldp port bidirection-detect warning
rldp port loop-detect warning
spanning-tree mst 0 cost 2000
spanning-tree mst 0 port-priority 16
description 30 let Pobedy 10

На портах в сторону клиентов выставлены:
spanning-tree mst 0 cost ХХ, где ХХ = 1000*<номер порта>
spanning-tree mst 0 port-priority YY, где YY = 16*<номер порта> - 16


Кольца присутствуют как в городе, не зависимо от ядра, так и замыкающиеся на ядре.

Конфигурация 3200-28:
Скрытый текст: показать
config stp version rstp
config stp maxage 20 maxhops 20 forwarddelay 15 txholdcount 6 fbpdu enable hellotime 2
config stp priority 16384 instance_id 0
config stp mst_config_id name 10.100.0.5 revision_level 0
config stp ports 1-24 externalCost auto edge true p2p auto state disable
config stp mst_ports 1-28 instance_id 0 internalCost auto priority 128
config stp ports 1-24 fbpdu disable
config stp ports 1-24 restricted_role true
config stp ports 1-24 restricted_tcn true
config stp loop_guard ports 1-28 state disable
config stp ports 25-28 externalCost auto edge false p2p auto state enable
config stp ports 25-28 fbpdu enable
config stp ports 25-28 restricted_role false
config stp ports 25-28 restricted_tcn false
enable stp

10.100.0.5 - IP свича, в данный момент свичей установлено 240 штук.
stp priority на всех свичах разный с инкрементом 4096.


Так же в сети летает GVRP. клиентские Vlan's с 2001 по 2199 подняты статически на 3610 и разлетаются по GVRP:
Скрытый текст: показать
Kernel#sh ru int vlan 2001
interface VLAN 2001
ip proxy-arp
ip address 10.200.1.1 255.255.255.0
arp timeout 300

Kernel#sh ru | in gvrp
gvrp enable
gvrp dynamic-vlan-creation enable


На DES-3200 так же включен GVRP, статически создается клиентский Vlan:
Скрытый текст: показать
# VLAN

disable asymmetric_vlan
enable pvid auto_assign
config vlan default delete 1-28
config vlan default advertisement enable
config vlan default add untagged 25-28
create vlan VLAN2005 tag 2005 advertisement
config vlan VLAN2005 add tagged 25-28
config vlan VLAN2005 add untagged 1-24
disable qinq
enable gvrp
config qinq ports 1-28 role nni outer_tpid 0x88A8 trust_cvid disable vlan_translation disable
config gvrp 1-24 state disable ingress_checking disable acceptable_frame admit_all pvid 2005
config gvrp 25-28 state enable ingress_checking disable acceptable_frame admit_all pvid 1


Вроде все по топологии.

Суть проблемы: при перестройке колец (возможно причина и не в этом) отваливается клиентский Vlan, т.е., на 3610 пропадают MAC адреса клиентских устройств. Сначала лечили reboot'ом 3200 на котором создан отпавший Vlan, теперь дошел до того, что достаточно на 3200 сказать
Код:
disable gvrp
enable gvrp


и все взлетает. Т.е., как я понимаю - я инизиализирую переанонсирование GVRP и, клиентские MAC-адреса благополучно появляются на голове.

Подскажите, пожалуйста, что я не докрутил в конфигах, или с чем это может быть связано.

Если я ковыряю не в ту сторону - дам любую другую инфу с конфигов свичей.

Заранее благодарен.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Пн июн 24, 2013 08:39 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Вт янв 18, 2011 13:29
Сообщений: 8986
Укажите, пожалуйста, версии прошивок.
Попробуйте выявить причину более точно, как вариант - ошибка может возникать из-за того, что при разблокировке резервного линка rstp на нем автоматически не анонсируются динамические vlan. Соберите больше информации и более тщательно проследите за ситуацией.
При возникновении проблемы опишите участок сети - кольцо, на котором проблема всплыла, и опишите точный порядок того, что в каком порядке происходило.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Пн июн 24, 2013 10:54 
Не в сети

Зарегистрирован: Ср сен 07, 2011 10:51
Сообщений: 22
sh ver
System description : DGS-3610-26G Gigabit Ethernet Switch
System start time : 2013-06-11 16:58:58
System uptime : 12:17:51:17
System hardware version : A1.0
System software version : v10.4(3) Release(117920)
System BOOT version : 10.3 Release(94612)
System CTRL version : 10.3 Release(94612)
Device information:
Device-1
Hardware version : A1.0
Software version : v10.4(3) Release(117920)
BOOT version : 10.3 Release(94612)
CTRL version : 10.3 Release(94612)

на A и C:
DES-3200R_1.82.B011.had и DES3200R_4.35.B012.had

Проблема возникает где угодно: "отваливаются" vlan как на свичах, учавствующих в колцьцах, так и в "аппендицитах", не учавствующих в кольцах.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Пн июн 24, 2013 11:48 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Вт янв 18, 2011 13:29
Сообщений: 8986
Artem Kolpakov писал(а):
Попробуйте выявить причину более точно, как вариант - ошибка может возникать из-за того, что при разблокировке резервного линка rstp на нем автоматически не анонсируются динамические vlan. Соберите больше информации и более тщательно проследите за ситуацией.
При возникновении проблемы опишите участок сети - кольцо, на котором проблема всплыла, и опишите точный порядок того, что в каком порядке происходило.

Еще раз.
У вас есть все возможности проанализировать проблему, описать ее точные симптомы и понять их, привести выводы соответствующих команд с устройств, сделать выводы. Это - ваша сеть, и у вас есть все инструменты, чтобы отловить ошибку. Почему вы это не делаете?
У меня возможности построить один-в-один вашу сеть и выполнить все эти действия за вас нет, а проблемами вида "что-то не работает" мы не занимаемся.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Пт сен 20, 2019 10:53 
Не в сети

Зарегистрирован: Ср сен 07, 2011 10:51
Сообщений: 22
всем спасибо, проблему решил отказом от GVRP и включением vlan_trunk :)

топик можно закрывать :)


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Чт окт 17, 2019 05:50 
Не в сети

Зарегистрирован: Ср окт 10, 2007 15:21
Сообщений: 310
Еще очень давно я тестировал gvrp и заметил косяк, что даже между 2-мя свитчами стоящими рядом влан взлетает не сразу, а с задержкой в 1-5 сек, а у клиентов это были бы постоянные жалобы, отказался от gvrp, а потом и от транка (в понимании циско), тк старые свитчи не знают такой команды, а те что знают, редут скорость по синусойде, я кстати тут создавал по этому вопросу тему и сами представители длинка это признали... Поэтому только хардкор, только add tagged на порт нужного влана.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Чт окт 17, 2019 14:36 
Не в сети

Зарегистрирован: Вс май 22, 2005 10:19
Сообщений: 890
Откуда: Moscow
gvrp - устаревшая фича, когда-то на свичах количество одновременно настраиваемых вланов было менее 4k и для транзита заранее не известного набора вланов придумали механизм их динамического анонса.
сейчас большинство современных свичей, кроме самых простеньких типа DGS-1100, умеют 4k вланов одновременно, и разумнее использовать vlan_trunk


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 7 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 6


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB