faq обучение настройка
Текущее время: Пт ноя 15, 2019 11:09

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 14 ] 
Автор Сообщение
СообщениеДобавлено: Чт май 05, 2011 16:16 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Добрый день.

Рассматривается устройство DSL-G804V (далее маршрутизатор) с прошивкой 1.00.08.dm15, которая на сегодняшний день является последней.

Столкнулся с явлением, которое принято называть как "утечка памяти". Такое явление происходит с двумя процессами: "/task/webserver" и "/task/dnsrelay", для которых числовые значения по резервируемой из "кучи" памяти можно получить при помощи команды "console process chips mem".

Приведенный протокол работы (файл в архиве "g804v_out_08dm15-out of memory-full.txt") был получен при помощи повторяющейся telnet-сессии (использовался telnet-клиент "plink.exe" из пакета PuTTY) с интервалом в 5 минут посредством стандартного планировщика задач ОС "Windows XP".

При более детальном анализе выяснилось, что каждый DNS-запрос навсегда "забирает" по 144 (сто сорок четыре) байта из "кучи", т.е. чем больше DNS-запросов, тем быстрее расходуется память.

В промежутке с "2011-05-04 7:45" до "2011-05-04 19:55" линк ADSL был в состоянии UP, но сессия PPPoE была разорвана (неприятность 2), что видно по системе мониторинга (файлы "g804v_out_08dm15-out of memory-full--pppoe_is_down_start.png" и "g804v_out_08dm15-out of memory-full--pppoe_is_down_end.png").

Для оценки загруженности маршрутизатора также приведен график с отображением трафика за последние сутки (файл "g804v_out_08dm15-out of memory-full--last_24h.png").

При этом запросы DNS продолжали поступать из внутренней сети, и память продолжала расходоваться. Также верно и обратное наблюдение - при отсутствии DNS-запросов память не расходуется.

При исчерпании всей свободной памяти маршрутизатор перестаёт выполнять свои функции - не работает маршрутизация, нет доступа к маршрутизатору ни через вэб-интерфейс, ни посредством telnet-сесии (доступ через консольный кабель не проверялся).

Работоспособность возвращается после выключения-включения по электропитанию.


Неприятность 2.

Иногда при разрыве сессии PPPoE маршрутизатор не восстанавливает её. В этом состоянии также не помогает кнопка "Connect/Disconnect" на владке "Status" в вэб-интерфейсе.

Аналогично пара команд
pppoe set transport wanlink disabled
pppoe set transport wanlink enabled

не приводит к должному результату - сессия PPPoE не восстанавливается.


Экспериментально выявлено, что восстановить PPPoE сессию без перезагрузки маршрутизатора возможно следующей парой команд:
port a1 set ActivateLine Abort
port a1 set ActivateLine Start


То есть путём выключения-включения WAN-ADSL интерфейса.

При таком разрыве сессии процесс "/task/ht_update" иногда забирает (на мой взгляд) очень много памяти, а также существенно возрастает загрузка CPU (файл "g804v_out_08dm15-PPPoE down.txt").


Описанные выше явления также стабильно наблюдаются в прошивках 1.00.08.dm14 и 1.00.08.dm12, а также в 1.00.08.dm08 (неприятность с PPPoE за время эксперимента не проявлялась).

Конфигурация маршрутизатора приведена в файле "settings.icf".
Некоторые адреса (IP/MAC) и логин-пароли изменены из соображений безопасности.

Архив с файлами: G804V.rar на FileShare.in.ua
Пароль: forum.dlink.ru

Хотелось бы узнать комментарии представителя компании "D-Link" по описанным выше проблемам, а также мнения форумчан.

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Пн май 16, 2011 11:45 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Up, актуально.

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Чт май 19, 2011 15:04 
Не в сети

Зарегистрирован: Вт дек 28, 2010 12:03
Сообщений: 25
Планируется закупка 60 таких устройств,но данный дефект огорчает - будет ли он устранен?


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Пт май 20, 2011 09:02 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Вт мар 01, 2011 22:06
Сообщений: 2025
DAurum писал(а):
Up, актуально.


С какой интенсивностью из внутренней сети "уходят" dns запросы?


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Сб май 21, 2011 16:51 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Oleg Syrbu писал(а):
С какой интенсивностью из внутренней сети "уходят" dns запросы?

Этот вопрос подтолкнул меня на очередное исследование проблемы. Для регистрации DNS-запросов на уровне пакетов использовался Kerio Wiroute Firewall. Снятие статистики с устройства DSL-G804V производилось вручную с интервалом 15 секунд (насколько это возможно сделать руками) в виде исполнения bat-файла. Сводный протокол в хронологической последовательности с комментариями приведен ниже:

Скрытый текст: показать
15:10:30,64 /task/dnsrelay 69248 0 0 16384 0 85632
15:10:45,68 /task/dnsrelay 69248 0 0 16384 0 85632
15:11:00,51 /task/dnsrelay 69248 0 0 16384 0 85632
15:11:15,53 /task/dnsrelay 69248 0 0 16384 0 85632
15:11:30,34 /task/dnsrelay 69248 0 0 16384 0 85632
--- Серия запросов (3 пакета)
[21/May/2011 15:11:43] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:11:43] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:53, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:25
[21/May/2011 15:11:43] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
[21/May/2011 15:11:43] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:488, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:460
[21/May/2011 15:11:43] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:53, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:25
[21/May/2011 15:11:43] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:488, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:460
--- объём резервируемой памяти увеличился на 69392-69248=144 байта
15:11:45,59 /task/dnsrelay 69392 0 0 16384 0 85776
--- Один запрос (1 пакет)
[21/May/2011 15:11:50] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:11:50] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
--- объём резервируемой памяти увеличился на 69600-69392=208 байтов
15:12:00,92 /task/dnsrelay 69600 0 0 16384 0 85984
15:12:15,75 /task/dnsrelay 69600 0 0 16384 0 85984
15:12:30,73 /task/dnsrelay 69600 0 0 16384 0 85984
--- Один запрос (1 пакет)
[21/May/2011 15:12:37] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:12:37] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
--- объём резервируемой памяти увеличился на 69744-69600=144 байта
15:12:45,71 /task/dnsrelay 69744 0 0 16384 0 86128
--- Серия запросов (19 пакетов), дополнительно отмечено, как получилось число 19.
1[21/May/2011 15:12:50] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:12:50] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
1[21/May/2011 15:12:51] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
1[21/May/2011 15:12:51] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
1[21/May/2011 15:12:51] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:12:51] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
3[21/May/2011 15:12:51] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:12:51] Last message repeated 3 times
[21/May/2011 15:12:51] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
[21/May/2011 15:12:51] Last message repeated 5 times
8[21/May/2011 15:12:51] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:12:51] Last message repeated 8 times
[21/May/2011 15:12:51] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
[21/May/2011 15:12:52] Last message repeated 8 times
4[21/May/2011 15:12:58] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:12:58] Last message repeated 4 times
[21/May/2011 15:12:58] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
[21/May/2011 15:12:59] Last message repeated 4 times
--- объём резервируемой памяти увеличился на 72704-69744=2960 байтов
15:13:01,32 /task/dnsrelay 72704 0 0 16384 0 89088
--- Серия запросов (4 пакета)
[21/May/2011 15:13:03] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:13:03] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:13:03] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
[21/May/2011 15:13:03] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
[21/May/2011 15:13:03] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:13:03] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
[21/May/2011 15:13:11] PERMIT "DNS-queries" packet to 3Com Etherlink ISA, proto:UDP, len:72, ip/port:192.168.183.55:1040 -> 192.168.183.1:53, udplen:44
[21/May/2011 15:13:11] PERMIT "DNS-queries" packet from 3Com Etherlink ISA, proto:UDP, len:149, ip/port:192.168.183.1:53 -> 192.168.183.55:1040, udplen:121
--- объём резервируемой памяти увеличился на 73344-72704=640 байтов (предположительно 144+144+144+208)
15:13:15,59 /task/dnsrelay 73344 0 0 16384 0 89728
15:13:30,59 /task/dnsrelay 73344 0 0 16384 0 89728
15:13:45,56 /task/dnsrelay 73344 0 0 16384 0 89728
15:14:00,85 /task/dnsrelay 73344 0 0 16384 0 89728
15:14:15,89 /task/dnsrelay 73344 0 0 16384 0 89728
15:14:30,87 /task/dnsrelay 73344 0 0 16384 0 89728

Суммарно за 4 минуты:
+ обработано 3+1+1+19+4=28 пакетов (запросов), частота запросов в данном исследовании составляет 28/4=7 запросов в минуту (1 запрос каждые 8.5 секунд)
+ объём резервируемой процессом /task/dnsrelay памяти увеличился на 73344-69248=4096 байтов.

Разумеется, в условиях эксплуатации частота (интенсивность) DNS-запросов существенно больше и может достигать нескольких десятков запросов в секунду.

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Чт май 26, 2011 12:59 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Вт мар 01, 2011 22:06
Сообщений: 2025
Данная проблема не повторилась.
[Для теста отправляли по dns запросу(nslookup) каждую секунду на протяжении минуты. Память отводимая под dnsrelay оставалась без изменений.]


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Чт май 26, 2011 17:38 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Oleg Syrbu писал(а):
Данная проблема не повторилась.
[Для теста отправляли по dns запросу(nslookup) каждую секунду на протяжении минуты. Память отводимая под dnsrelay оставалась без изменений.]

Предлагаю перенести продолжение в ЛС.

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Пн май 30, 2011 10:51 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Прежде всего хочу поблагодарить за уделённое данной теме внимание.

Проблема проявляется, если источник DNS-запроса находится за NAT'ом.

Вы можете легко воспроизвести эксперимент, выполнив указанные ниже шаги.

Оборудование: DSL-G804V (f/w: 1.00.08.dm15), DSL-2640U/BRU/C (f/w: RU_1.25, Nov.29,2010), компьютер с Windows XP (это как раз не принципиально).

Коммутация:
Порт 1 устройства DSL-2640U/BRU/C соединён обычным (т.е. прямым) патч-кордом с портом 1 (можно также 2,3,4) устройства DSL-G804V.
Ethernet-порт компьютера, с которого производится тестирование, соединён обычным патч-кордом с портом 4 (можно также 2,3) устройства DSL-2640U/BRU/C.

Для опроса устройства DSL-G804V используется BAT-файл (query.bat) следующего содержания:
Скрытый текст: показать
Код:
@echo off
set logname=g804v_out.txt
set cmdfile=g804v_cmd.txt
set telnet_cmd=plink.exe -telnet 192.168.1.1

set curtime=%time%
set curdate=%date%
set curdate=%curdate:~6,4%.%curdate:~3,2%.%curdate:~0,2%
echo ########dnsrelay########## %curdate%-%curtime% > %logname%
%telnet_cmd% < %cmdfile% >> %logname%

set curtime=%time%
set curdate=%date%
set curdate=%curdate:~6,4%.%curdate:~3,2%.%curdate:~0,2%
echo ########dnsrelay########## %curdate%-%curtime% nslookup www.dlink.com >> %logname%
ipconfig /flushdns
nslookup www.dlink.com
%telnet_cmd% < %cmdfile% >> %logname%

type %logname% | find "dnsrelay"


plink.exe - утилита для работы с командной строки из пакета PuTTY.

Команды берутся из файла g804v_cmd.txt со следующим содержимым (в конце - пустая строка):
Скрытый текст: показать
Код:
admin
admin
console process chips mem
user logout




Конфигурация устройства DSL-G804V.

Установить заводские настройки. Дождаться завершения перезагрузки.
Выключить Wi-Fi (чтобы не было "гостей" в открытую по-умолчанию сеть): Home --> Wireless --> WLAN Radio (установить Off) --> Apply.
Сохранить конфигурацию: Tools --> System --> Save.


Конфигурация устройства DSL-2640U/BRU/C.

Установить заводские настройки: Management --> Restore Default
Выключить Wi-Fi (чтобы не было "гостей" в открытую по-умолчанию сеть): Wireless --> Basic (снять "Enable Wireless" --> Save/Apply).
Сконфигурировать WAN: Advanced Setup --> WAN (Add --> Next --> PPPoE --> Next --> Next --> Next --> Save).
Изолировать LAN1: Advanced Setup --> Interface Group (установить "Enable virtual ports on: eth0" --> Save/Apply, Add --> Group Name: Outside, LAN1, "<-", Save/Apply).
Сконфигурировать LAN: Advanced Setup --> LAN (IP Address: 192.168.200.1, Save). Вынужденная перезагрузка.

В консоли:

логин(admin)
пароль(admin)
sh

ifconfig br1 192.168.1.2 netmask 255.255.255.0 broadcast 192.168.1.255
route add -net 0.0.0.0 netmask 0.0.0.0 gw 192.168.1.1 metric 1

iptables -t nat -F
iptables -t nat -A POSTROUTING -o br1 -s 192.168.200.0/255.255.255.0 -j MASQUERADE

iptables -F INPUT
iptables -A INPUT -i br0 -d 192.168.200.1 -s 192.168.200.0/255.255.255.0 -j ACCEPT
iptables -A INPUT -i br1 -j DROP

iptables -F FORWARD
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i br0 -s 192.168.200.0/255.255.255.0 -j ACCEPT
iptables -A FORWARD -j DROP



Тестирование.

На компьютере, с которого производится тестирование, установить получение адреса по DHCP и задать вручную DNS = 192.168.1.1

ТЕСТ
Код:
>query.bat

Настройка протокола IP для Windows

Успешно сброшен кэш распознавателя DNS.
Server:  DSL-G804V
Address:  192.168.1.1

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to DSL-G804V timed-out
########dnsrelay########## 2011.05.29-22:27:25,96
 /task/dnsrelay             8192        0        0    16384        0     24576
########dnsrelay########## 2011.05.29-22:27:26,47 nslookup www.dlink.com
 /task/dnsrelay             8192        0        0    16384        0     24576


Утечки нет.


Добавляю через консоль в DSL-2640U/BRU/C
----------------------------------------------------
iptables -t nat -A PREROUTING -p udp -i br0 -s 192.168.200.0/255.255.255.0 -d 192.168.200.1 --destination-port 53 -j DNAT --to-destination 192.168.1.1
На компьютере, с которого производится тестирование, установить получение адреса по DHCP и задать вручную DNS = 192.168.200.1
----------------------------------------------------

ТЕСТ
Код:
>query.bat

Настройка протокола IP для Windows

Успешно сброшен кэш распознавателя DNS.
DNS request timed out.
    timeout was 2 seconds.
*** Can't find server name for address 192.168.200.1: Timed out
*** Default servers are not available
Server:  UnKnown
Address:  192.168.200.1

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out
########dnsrelay########## 2011.05.29-22:28:59,21
 /task/dnsrelay             8192        0        0    16384        0     24576
########dnsrelay########## 2011.05.29-22:28:59,66 nslookup www.dlink.com
 /task/dnsrelay             8400        0        0    16384        0     24784


Утечка ЕСТЬ.


Создаётся такое впечатление, что проблема именно в этой самой строке с DNAT. Однако если её удалить, то проблема всё равно повторяется, только не сразу.
Кто-то может сказать: "Так ведь вы же используете устройство DSL-2640U/BRU/C в нештатном режиме". Не вопрос, маршрутизатор Cisco 881 с представленной ниже конфигурацией даёт такой же результат.
Скрытый текст: показать
Код:
Router#show run
Building configuration...

Current configuration : 1459 bytes
!
! Last configuration change at 04:17:14 UTC Mon May 30 2011
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
memory-size iomem 10
!
!
ip source-route
!
!
ip dhcp excluded-address 192.168.200.1
!
ip dhcp pool NET-192.168.200-24
   network 192.168.200.0 255.255.255.0
   default-router 192.168.200.1
   dns-server 192.168.1.1
!
!
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO881-SEC-K9 sn ***********
!
!
username admin privilege 15 secret 5 $1$01WI$YTdaXiso0d52dO0hMfSbP0
!
!
!
!
!
!
!
!
!
interface FastEthernet0
 !
!
interface FastEthernet1
 !
!
interface FastEthernet2
 !
!
interface FastEthernet3
 !
!
interface FastEthernet4
 ip address 192.168.1.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 !
!
interface Vlan1
 ip address 192.168.200.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 !
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list Fa4_PAT interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip access-list extended Fa4_PAT
 permit ip 192.168.200.0 0.0.0.255 any
!
no cdp run

!
!
!
!
!
control-plane
 !
!
!
line con 0
 no modem enable
 length 55
 width 100
line aux 0
line vty 0 4
 login
!
scheduler max-task-time 5000
end

Вполне возможно, что эта самая строка с DNAT "запускает" процесс утечки, но это просто догадка.

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Вт июн 07, 2011 09:47 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Up

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Чт июн 16, 2011 14:27 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Up

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср июн 29, 2011 10:21 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Up

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Пн июл 11, 2011 09:44 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Up

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Пт июл 22, 2011 14:40 
Не в сети

Зарегистрирован: Вт окт 26, 2010 15:22
Сообщений: 403
Up

_________________
Использую DSL-G804V в качестве Ethernet-маршрутизатора.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Чт дек 01, 2011 10:51 
Не в сети

Зарегистрирован: Вт сен 28, 2010 19:23
Сообщений: 29
Откуда: Ижевск
Up


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 14 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 34


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB