faq обучение настройка
Текущее время: Вт ноя 24, 2020 04:18

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 9 ] 
Автор Сообщение
 Заголовок сообщения: DGS-3130-30S и dhcp local-relay
СообщениеДобавлено: Пн мар 30, 2020 15:40 
Не в сети

Зарегистрирован: Чт мар 05, 2009 11:21
Сообщений: 88
Всем привет
Взял попробовать свитч DGS-3130-30S на замену полюбившимся DGS-3120-24SC
Код:
Unit ID  Module Name         Versions
-------  ------------------  ---------------------
1        DGS-3130-30S        H/W:A1
                             Bootloader:1.00.006
                             Runtime:1.12.B002


Пробую настроить на нём dhcp_local_relay, который теперь тут "ip dhcp local-relay", но почему-то опция 82 не добавляется в пакеты
Порт 25 - аплинк, порт 26 - клиент. Если честно, уже всё подряд пытался включать пока разбирался, поэтому возможно что-то не в тему

Скрытый текст: показать
Код:
Switch#show running-config

!Current Configuration:
!
!System Description "DGS-3130-30S"
!System Software Version "1.12.B002"
!System Up Time          "0 days 1 hrs 23 mins 42 secs"
!Current SNTP Synchronized Time: SNTP Client Mode Is Disabled
!
member 1 5

configure terminal
exit
configure terminal
exit
configure terminal
exit
configure terminal
no aaa new-model
vlan 2535
exit
username admin privilege 15 password 0 strongpassword
ssh user admin authentication-method password
line console
exit

line telnet
login local
exit

line ssh
login local
exit


ip dhcp snooping
ip dhcp snooping information option allow-untrusted
ip dhcp snooping vlan 2535
ip dhcp relay information option
ip dhcp local-relay vlan 2535
no interface vlan 1

interface ethernet 1/0/25
switchport mode trunk
switchport trunk allowed vlan 1,2535
ip dhcp snooping trust
exit



interface ethernet 1/0/26
switchport mode access
switchport access vlan 2535
exit


interface mgmt 0
ip address 192.168.0.1 255.255.255.0
exit
interface vlan 1
ip address 10.110.110.193 255.255.255.0
exit

interface null 0
exit
ip route 0.0.0.0 0.0.0.0 10.110.110.254 weight 1
exit

В общем, что ни делаю, на выходе получаю пакет без опции82. Проблема с прошивкой или я что-то не так сделал?


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DGS-3130-30S и dhcp local-relay
СообщениеДобавлено: Пн мар 30, 2020 20:20 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Пт янв 21, 2005 11:52
Сообщений: 11201
Откуда: D-Link, Moscow
Добрый день.

Вам нужно добавить:
con t
service dhcp
end

_________________
С уважением,
Бигаров Руслан.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DGS-3130-30S и dhcp local-relay
СообщениеДобавлено: Пн мар 30, 2020 21:06 
Не в сети

Зарегистрирован: Чт мар 05, 2009 11:21
Сообщений: 88
Bigarov Ruslan писал(а):
Добрый день.

Вам нужно добавить:
con t
service dhcp
end

Спасибо, завтра попробую
В мануале в описании "ip dhcp local-relay" не было сказано, что надо включать сервис. Впервые сталкиваюсь с этой серией свитчей

UPD. сейчас поискал по мануалу "service dhcp" и обнаружил, что необходимость включения сервиса есть в куче мест, но только не в описании "ip dhcp local-relay"


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DGS-3130-30S и dhcp local-relay
СообщениеДобавлено: Вт мар 31, 2020 13:53 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Пт янв 21, 2005 11:52
Сообщений: 11201
Откуда: D-Link, Moscow
Пожалуйста, напишите по результатам.

_________________
С уважением,
Бигаров Руслан.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DGS-3130-30S и dhcp local-relay
СообщениеДобавлено: Вт мар 31, 2020 14:54 
Не в сети

Зарегистрирован: Чт мар 05, 2009 11:21
Сообщений: 88
Bigarov Ruslan писал(а):
Пожалуйста, напишите по результатам.

Всё работает, спасибо


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DGS-3130-30S и dhcp local-relay
СообщениеДобавлено: Вт мар 31, 2020 17:44 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Пт янв 21, 2005 11:52
Сообщений: 11201
Откуда: D-Link, Moscow
Рад слышать.

_________________
С уважением,
Бигаров Руслан.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DGS-3130-30S и dhcp local-relay
СообщениеДобавлено: Пн окт 19, 2020 13:37 
Не в сети

Зарегистрирован: Пн окт 19, 2020 13:20
Сообщений: 2
Добрый день
Имеем на узле DGS-3130-30S и DGS-3120-24SC аплинк на DGS-3130 с него DGS-3120 имеем проблему если в dhcp local-relay vlan прописан на обоих УК то от клиентов с DGS-3120 пакеты приходят без опции 82, клиенты с DGS-3130 получают настройки нормально. Если на DGS-3120 удалить dhcp local-relay клиенты начинают работать.

Такой проблемы нет в других местах где стоят несколько DGS-3120-24SC или DGS-3120-24SC с DES-3200-28F

Какие то настройки не докручиваю? В DGS-3120-24SC есть настройки как обрабатывать опции 82 по портам, а вот в DGS-3130 чего-то подобного не нахожу


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DGS-3130-30S и dhcp local-relay
СообщениеДобавлено: Вт окт 20, 2020 14:54 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Пт янв 21, 2005 11:52
Сообщений: 11201
Откуда: D-Link, Moscow
Добрый день.

Так как DGS-3130 - это коммутатор уровня агрегации, то все настройки DHCP Relay и DHCP Local Relay у него per VLAN. Если у Вас VLAN-ы пересекаются с ниже стоящими коммутаторами, то есть два варианта:

1. Более безопасный: Настроить так, чтобы VLAN-ы доступа не пересекались, а на DGS-3130 включить DHCP Local Relay тольк для VLAN, которые у него распакованы на портах доступа.

2. Менее безопасный: Настроить Policy keep в этом VLAN:
ip dhcp relay inf policy-action keep

_________________
С уважением,
Бигаров Руслан.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DGS-3130-30S и dhcp local-relay
СообщениеДобавлено: Ср окт 21, 2020 13:38 
Не в сети

Зарегистрирован: Пн окт 19, 2020 13:20
Сообщений: 2
по первому варианту и вышли из ситуации, что потребовало дополнительных как физических так и логический действий. Но хотелось понять это не хватает настроек или поменялась логика (в DGS3120 работало без проблем)

второй вариант не изменил ситуации, клиенты со второго УК не получают настроек

Скрытый текст: показать
ip dhcp snooping
ip dhcp snooping information option allow-untrusted
service dhcp
ip dhcp relay information option
ip dhcp local-relay vlan 2224

interface vlan 2224
ip dhcp relay information policy-action keep
exit

interface ethernet 1/0/25
switchport mode trunk
spanning-tree loop-guard
exit


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 9 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 21


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB