faq обучение настройка
Текущее время: Сб фев 29, 2020 11:00

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 5 ] 
Автор Сообщение
 Заголовок сообщения: DFL 260E & Mikrotik
СообщениеДобавлено: Вт апр 30, 2019 13:27 
Не в сети

Зарегистрирован: Пн июн 04, 2012 18:05
Сообщений: 311
Добрый день, коллеги!
Есть DFL260E который используется как интернет-шлюз (прошивка последняя, 12-я) и в роли сервера L2TP over Ipsec. На DFL настроено еще резервирование основного канала, но в этом случае наличие интернета необходимо только для локальной сети за DFL, подключение удаленных клиентов непринципиально, т.е. при отключении основного канала, DFL переходит на резервный, и в этом случае становится недоступен для удаленных клиентов.
Есть порядка 10 пользователей (удаленные клиенты все на windows), который цепляются к DFL и работают с доступными им ресурсами.
Mikrotik 1100 ahx4 (прошивка последняя стабильная на момент создания темы) также является клиентом, пользователям за микротиком доступен ряд ресурсов в локальной сети за DFL.
Вот что наблюдается: большую часть времени связь между двумя железяками относительно стабильна (есть обрывы, но незначительны), но порой микротик не может прицепиться к DFL очень длительное время. Контакт происходит только после того, как руками перезапускается DFL.
Микротик постоянно мониторится, из локалки за DFL он регулярно пингуется, также пингуется оборудование стоящее за микротиком.
В логах микротика видно, что он застревает на 1-й фазе, дальше соединение не проходит.
Если есть мысли на сей счет, просьба поделиться.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DFL 260E & Mikrotik
СообщениеДобавлено: Вт апр 30, 2019 14:01 
Не в сети

Зарегистрирован: Вт фев 26, 2008 19:07
Сообщений: 8957
Откуда: Москва
есть конечно ... !
надо выяснять в чем причина ...
посмотреть - нет ли зависшей сессии на DFL ?! Посмотреть часы (время) посмотреть логи на DFL (если не получается сделать SYSlog - смотреть там) поменять тип туннеля - например на L2tp.
исходя из полученной информации делать выводы ... Волшебного порошка нет ...

_________________
Своим вопросом Вы загоняете меня в ГУГЛ.....
DFL-210 -архив образов
Меня можно найти в боте Телеграмма @MyKingdombot когда РКН перестанет заниматься ерундой :-)
Готовыe платить - пишите
Прикуплю неисправные девайсы ради корпусов ....-> в личку


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DFL 260E & Mikrotik
СообщениеДобавлено: Вт апр 30, 2019 15:11 
Не в сети

Зарегистрирован: Пн июн 04, 2012 18:05
Сообщений: 311
Часы в норме, тип туннеля менять нельзя.
Логи есть, это уже запланировано.
А чуть более подробно рассказать про зависшую сессию на DFL можно?
С методологией решения проблем я знаком.
Я не прошу волшебного порошка, а хочу что бы участники форума поделились своими мнениями, возможно аналогичная или похожая ситуация у кого либо уже возникала.
И есть наработки по ее решению.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DFL 260E & Mikrotik
СообщениеДобавлено: Ср май 01, 2019 18:54 
Не в сети

Зарегистрирован: Вт июл 10, 2007 12:42
Сообщений: 7179
Откуда: Екатеринбург
Дельных мыслей нет.

Как костыль можно попробовать применить скрипт, который на Mikrotik используют для подвисшего usb модема. Я его аналог использовал в подобной ситуации, Только тоннель был просто l2tp.

Суть проста, в планировщике каждые x минут проверяется, есть ли пинг DFL. Если нет - перезапуск туннеля на mikrotik (disable/enable). Мне помогает.

пример:

Код:
##### Script Settings #####
:local WanName "l2tp-office"
:local HostPingA "192.168.1.254"
:local filename "Reconnect_L2TP"
#####################

:local PingCount "5"
:local pingresultA [/ping $HostPingA count=$PingCount];

:if ($pingresultA = 0) do={
    :log error message="Script can not ping thru <$WanName>. Try to reconnect...";
    :interface l2tp-client disable $WanName;
    :delay 15;
    :interface l2tp-client enable $WanName;
    :log warning message="<$WanName> has Reconnected by script";

    :local date [/system clock get date];
    :local time [/system clock get time];
    :local cont "$date $time\r\n";

    /file set $filename contents=([get $filename contents] . $cont);
}

Вероятно, эти строки можно выкинуть без потери функционала.
:interface l2tp-client disable $WanName;
:delay 15;

и попытки логирования в файл тоже

_________________
6 x DFL-210, 2 x DFL-800. Для DFL-210/260/800/860 лучшая прошивка 2.27.08.03 (for WW). СКАЧАТЬ.
Совет: Не используйте в IP- и Routing-правилах сочетание any/all-nets нигде, кроме временных правил. Иначе возможны бреши в безопасности и несрабатывание последующих правил.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: DFL 260E & Mikrotik
СообщениеДобавлено: Чт май 09, 2019 19:18 
Не в сети

Зарегистрирован: Пн июн 04, 2012 18:05
Сообщений: 311
Сделал следующее: на DFL в настройках IKE (Phase-1) выставил параметр Lifetime равный 86400, аналогично сделал и на Микротике.
И вот уже три дня полет нормальный.


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 5 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на форуме

Сейчас этот форум просматривают: Google [Bot] и гости: 17


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB