faq обучение настройка
Текущее время: Пт дек 06, 2019 12:10

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 14 ] 
Автор Сообщение
 Заголовок сообщения: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Ср май 08, 2013 13:56 
Не в сети

Зарегистрирован: Ср май 08, 2013 13:29
Сообщений: 8
Всем, здравствуйте! Есть 2 DES-3810-28 соединенных между собой напрямую, к каждому подключен компьютер. Настроен OSPF, компьютеры пингуются.Подскажите как правильно настроить MPLS/LDP или дайте мануал толковый желательно на русском, но на английском тоже сойдет.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Пн май 13, 2013 12:42 
Не в сети

Зарегистрирован: Ср май 08, 2013 13:29
Сообщений: 8
Что, никто не знает???


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Пн май 13, 2013 13:20 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Вт янв 18, 2011 13:29
Сообщений: 8986
Я запрошу пример в ШК.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Ср май 15, 2013 09:21 
Не в сети

Зарегистрирован: Ср май 08, 2013 13:29
Сообщений: 8
Artem Kolpakov писал(а):
Я запрошу пример в ШК.

Это надолго? Просто хочется понять, ждать ответа или эта технология не реализована как следует и необходимо искать альтернативные варианты.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Ср май 15, 2013 10:00 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Вт янв 18, 2011 13:29
Сообщений: 8986
Ждите ответа.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Чт май 16, 2013 10:43 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Вт янв 18, 2011 13:29
Сообщений: 8986
удалено


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Чт май 16, 2013 13:54 
Не в сети

Зарегистрирован: Ср май 08, 2013 13:29
Сообщений: 8
Спасибо! СЕ1 и СЕ2 пингуют друг друга, но почему порты без тега одновременно в двух вланах? И почему в выводе show mpls lsp пусто?


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Чт май 16, 2013 13:56 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Вт янв 18, 2011 13:29
Сообщений: 8986
Приведите, пожалуйста, выводы соответствующих команд


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Чт май 16, 2013 14:02 
Не в сети

Зарегистрирован: Ср май 08, 2013 13:29
Сообщений: 8
Таблица VLANs:
Код:
DES-3810-28:admin#sh vlan
Command: show vlan


VLAN Trunk State        : Disabled
VLAN Trunk Member Ports :


VID             : 1               VLAN Name     : default
VLAN Type       : Static          Advertisement : Enabled
Member Ports    : 1-28
Static Ports    : 1-28
Current Tagged Ports  :
Current Untagged Ports: 1-28
Static Tagged Ports   :
Static Untagged Ports : 1-28
Forbidden Ports       :

VID             : 10              VLAN Name     : VLAN10
VLAN Type       : Static          Advertisement : Disabled
Member Ports    : 2
Static Ports    : 2
Current Tagged Ports  :
Current Untagged Ports: 2
Static Tagged Ports   :
Static Untagged Ports : 2
Forbidden Ports       :

Total Static VLAN Entries: 2
Total GVRP VLAN Entries: 0


Таблица LSP:
Код:
DES-3810-28:admin#show mpls lsp
Command: show mpls lsp

 No Entry


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Вт май 21, 2013 08:37 
Не в сети

Зарегистрирован: Пт авг 21, 2009 11:14
Сообщений: 6
Откуда: Нижневартовск
продолжу тему, чтобы не создавать новую.
стенд из 4-х DES-3810-28, фулмеш 3го уровня (6 линков-пиров в отдельных подсетях), OSPF, MPLS/LDP

проблема 1. очень часто без видимых закономерностей после создания VPWS цепочки приходится дёргать LDP чтобы цепочка заработала.

проблема 2. при ручном указании меток (inbound/outbound) во время создания VPWS не происходит передача этой информации соседу по LDP (смотрю вайршарком). если дать коммутатору возможность выбрать метку самому (он начинает с 1000 для первого vc) то обновление по LDP происходит нормально.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Ср май 22, 2013 14:21 
Не в сети
Сотрудник D-LINK
Сотрудник D-LINK

Зарегистрирован: Вт янв 18, 2011 13:29
Сообщений: 8986
Поступила уточняющая информация от разработчиков, описанный выше стенд несколько некорректен т.к. DES-3810 поддерживает только L2VPN (VPWS) не может использоваться как P-устройство. Соответственно, для работы нужно еще одно устройство для построения LSP.

[Topology]
CE1 -- (port1) DES-3810_1 ----MPLS device---- DES-3810_2 (port2) -- CE2

[Config]
#DES-3810_1
Скрытый текст: показать
create loopback ipif lo 1.1.1.1/24
config ipif System ipaddress 192.168.1.1/24
config mpls ipif System state enable
enable mpls
config ldp lsr_id ipif lo
config ldp ipif System state enable
enable ldp
create ldp targeted_peer 2.2.2.2
config vpws type eth_raw
create vpws vc 1 peer 2.2.2.2 port 1
config ospf router_id 1.1.1.1
config ospf ipif System state enable
config ospf ipif lo state enable
enable ospf


#DES-3810_2
Скрытый текст: показать
create loopback ipif lo 2.2.2.2/24
config ipif System ipaddress 192.168.2.2/24
config mpls ipif System state enable
enable mpls
config ldp lsr_id ipif lo
config ldp ipif System state enable
enable ldp
create ldp targeted_peer 1.1.1.1
config vpws type eth_raw
create vpws vc 1 peer 1.1.1.1 port 2
config ospf router_id 2.2.2.2
config ospf ipif System state enable
config ospf ipif lo state enable
enable ospf


#MPLS device (DXS-3600)
Скрытый текст: показать
config vlan default delete 1-24
create vlan 10 t 10
config vlan 10 add u 1
create vlan 20 t 20
config vlan 20 add u 2
create ipif 10 192.168.1.2/24 10 state enable
create ipif 20 192.168.2.1/24 20 state enable
configure terminal
interface loopback 1
ip address 3.3.3.3 255.255.255.0
exit
mpls ip
mpls label protocol ldp
ldp router-id 3.3.3.3
exit
interface vlan 10
mpls label protocol ldp
mpls ip
exit
interface vlan 20
mpls label protocol ldp
mpls ip
exit
router ospf
router-id 3.3.3.3
network 192.168.1.0 255.255.255.0 area 0.0.0.0
network 192.168.2.0 255.255.255.0 area 0.0.0.0
network 3.3.3.0 255.255.255.0 area 0.0.0.0
exit
exit


Непосредственно соединять DES-3810 между собой некорректно в виду описанных причин.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Ср май 22, 2013 22:04 
Не в сети

Зарегистрирован: Ср май 08, 2013 13:29
Сообщений: 8
Спасибо за ответ!


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Вт сен 03, 2013 07:47 
Не в сети

Зарегистрирован: Пт авг 21, 2009 11:14
Сообщений: 6
Откуда: Нижневартовск
спасибо за разъяснения


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Настройка MPLS сети на DES-3810-28
СообщениеДобавлено: Вт мар 11, 2014 11:30 
Не в сети

Зарегистрирован: Пт авг 21, 2009 11:14
Сообщений: 6
Откуда: Нижневартовск
возникла проблема в работе протокола LDP при подключении DES-3810-28 к существующей сети MPLS.
Цитата:
DES-3810-28:admin#show ldp
Command: show ldp

LSR ID : 10.110.9.243
LDP Version : 1.0
LDP State : Enabled
TCP Port : 646
UDP Port : 646
Max PDU Length : 1500
Max Backoff : 600 Seconds
Transport Address : 10.110.9.243
Keep Alive Time : 40 Seconds
LSP Control Mode : Independent
Label Retention : Liberal
Loop Detection : Disabled
Path Vector Limit : 254
Hop Count Limit : 254
Authentication : Disabled
PHP : Implicit null
Trap Status : Disabled
Log Status : Enabled


DES-3810-28:admin#show ldp peer
Command: show ldp peer

Peer : 10.110.9.254:0
--------------------------------------
Protocol Version : 1.0
Transport Address : 10.110.9.254
Keep Alive Time : 45 seconds
Distribute Method : DU
Loop Detect : Disabled
Path Vector Limit : 0
Max PDU Length : 4096


Total Entries: 1

DES-3810-28:admin#show ldp statistic
Command: show ldp statistic

SessionAttempts : 0
SessionRejectedNoHelloErrors : 0
SessionRejectedAdErrors : 0
SessionRejectedMaxPduErrors : 0
SessionRejectedLRErrors : 0
BadLdpIdentifierErrors : 0
BadPduLengthErrors : 410
BadMessageLengthErrors : 0
BadTlvLengthErrors : 0
MalformedTlvValueErrors : 0
KeepAliveTimerExpErrors : 0
ShutdownReceivedNotifications: 0
ShutdownSentNotifications : 410


существует ли механизм регулирования максимального размера пакета протокола LDP на DES-3810-28?


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 14 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на форуме

Сейчас этот форум просматривают: Google [Bot] и гости: 19


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB